Proposer: Wim Meeussen
Present at review:
- List reviewers
Question / concerns / comments
Enter your thoughts on the API and any questions / concerns you have here. Please sign your name. Anything you want to address in the API review should be marked down here before the start of the meeting.
The name 'dom_parser.hpp' doesn't provide much useful context. What is dom? Could this file just be kdl_parser.h? If not, at least give a hint somewhere on the wiki page as to what DOM stands for.
kdl_parser::treeFromRobotModel builds a tree from a urdf::Model. Thus, maybe this function should be called kdl_parser::treeFromUrdfModel?
- Add lines to the xml example, showing type information for xml_doc.
- Assuming that doxygen is populated, I would link to the various function descriptions from the wiki.
- adding to Vijay's comment, 'dom_parser' might be ok if you are planning to support multiple robot description formats in the future.
- adding const to all converter function input parameters
To be filled out by proposer based on comments gathered during API review period
Package status change mark change manifest)
Action items that need to be taken.
Major issues that need to be resolved