API review

Proposer: Tully Foote

Present at review:

  • List reviewers

Question / concerns / comments

Renaming what to rename to?

  • kwc: per naming conventions, ocean_ibps, ibsp_battery, or ocean_ibsp_battery would be reasonable names. 'interface' seems redundant

    • 'monitorBatteries' can be shortened to 'monitor'


  • kwc: non-indented comment style makes reading code very difficult
  • kwc: main loop is very difficult to read
  • kwc: IBPSBatteryInterface/parseIBPS is nearly identical to monitorBatteries

Meeting agenda

To be filled out by proposer based on comments gathered during API review period


Package status change (also mark change on PackageStatusDict page)

  • /!\ Action items that need to be taken.

  • {X} Major issues that need to be resolved

  • /!\ Change name to ocean_battery_driver

  • /!\ Remove parseIBPS; add command-line option to monitor to run without ROS and just output data to screen

  • /!\ Implement SelfTest service (just reports that it's happily talking to N ports)

  • /!\ Rename batteryStatusPanel.fbp to battery_status_panel.fbp and pr2BatteryPanel.xrc battery_status_panel.xrc

Result: API conditionally cleared.

Wiki: ocean_battery_driver/Reviews/2008-12-11_API_Review (last edited 2009-08-14 20:51:33 by localhost)