API review
Proposer: Tully Foote
Present at review:
- List reviewers
Question / concerns / comments
Enter your thoughts on the API and any questions / concerns you have here. Please sign your name. Anything you want to address in the API review should be marked down here before the start of the meeting.
Meeting agenda
To be filled out by proposer based on comments gathered during API review period
Conclusion
Package status change mark change manifest)
Action items that need to be taken.
Major issues that need to be resolved
- Move image_msgs to sensor_msgs
Move ColoredLine/ColoredLines from image_msgs to visualization_msgs
Move ParticleCloud to nav_msgs (Think about adding weights to the particle cloud)
- Move Diagnostic* to diagnostic_msgs from robot_msgs (Think about renaming them)
Move Table, ObjectOnTable, and AttachedObject from robot_msgs to tabletop_msgs
Move Door, OutletPose, and PlugStow from robot_msgs to the plugs or doors package
Move OccGrid from robot_msgs to nav_msgs
- Move Kinematic* from robot_msgs to kinematic_planning_msgs
Move JointState, ActuatorState, and MechanismState from robot_msgs to mechanism_msgs
JointCmd --- find out what this is and what uses it and why... maybe we can get rid of it (Ticket Stu to look into this), for now... move JointCmd to deprecated_msgs
Move TrajectoryPoint, RobotTrajectory, JointTrajPoint, and JointTraj from robot_msgs to manipluation_msgs
Move PolygonalMap, CollisionMap, and OrientedBoundedBox from robot_msgs to manipulation_msgs (Think about moving them elsewhere later)
Make audio_msgs experimental package and move AudioRawStream from robot_msgs to it
Move TaskFrameFormalism from robot_msgs to manipulation_msgs
- Change VOPose to be Pose?Weighted
Replace Acceleration, Velocity, AngularAcceleration, and AngularVelocity with Vector3
Remove TestData from robot_msgs... put it in the trash
Replace PoseDot and PoseDDot in robot_msgs with Twist
Change robot_msgs PoseWithRatesStamped to use Twist and rename it to PoseWithRates
Move PoseConstraint from robot_msgs to kinematic_planning_msgs
Move CartesianState from robot_msgs to robot_mechanism_controllers
Work on removing ControllerStatus from robot_msgs and as a msg in general
Move PositionMeasurement from robot_msgs to people
Move BatteryState from robot_msgs to pr2_msgs
Remove Polyline from visualization_msgs and change all uses of it to either publish PointClouds or some new thing that might be called a Path... in fact... it will be a Path... with color removed
- Polygon3D will become Polygon... lose its color... and stay in robot_msgs
- Replace image_msgs/ImagePoint with Point and ignore z