Proposer: Brian Gerkey
Present at review:
- Josh Faust
- Tully Foote
- Ken Conley
Question / concerns / comments
Enter your thoughts on the API and any questions / concerns you have here. Please sign your name. Anything you want to address in the API review should be marked down here before the start of the meeting.
- Ken: rospack_ prefix nomenclature is a misnomer and klunky, but probably not worth changing at this point.
- Josh: rospack_is_test_harness is poorly named.
- Ken should write a script to validate usage of rospack(package_name)
To be filled out by proposer based on comments gathered during API review period
Package status change mark change manifest)
Action items that need to be taken.
Major issues that need to be resolved
rospack_is_test_harness -> rospack_declare_test
write a Hudson script to audit rospack(package_name) (not required for release)
API Conditional Pass